Discussion:
Problem mit GPS-Tuner, Waypoints in OSM
(too old to reply)
Kai Behncke
2008-05-06 11:52:58 UTC
Permalink
Hallo liebe Liste,

ich erhebe meine Daten mit der Software "GPS Tuner". Ich habe da nun Wegpunkte abgespeichert die ich nun in JOSM bearbeiten möchte.
Wenn ich allerdings meine Waypoint-gpx-Datei einladen möchte erhalte ich die Nachricht:

Error while parsing......Content is not allowed in prolog.


Was kann ich tun um die Daten dennoch einlesen zu können?
Danke im Voraus, Kai
--
Psssst! Schon vom neuen GMX MultiMessenger gehört?
Der kann`s mit allen: http://www.gmx.net/de/go/multimessenger
Frederik Ramm
2008-05-06 12:07:06 UTC
Permalink
Hallo,
Post by Kai Behncke
ich erhebe meine Daten mit der Software "GPS Tuner". Ich habe da nun Wegpunkte abgespeichert die ich nun in JOSM bearbeiten möchte.
Error while parsing......Content is not allowed in prolog.
Kannst Du uns so eine Datei mal irgendwo zum Download bereitstellen?

Bye
Frederik
Kai Behncke
2008-05-06 12:33:55 UTC
Permalink
Hallo Frederik,

danke für die Bemühungen.
Ich habe das relevante GPX-File hier bereit gestellt:

http://www.selbstverwaltung-bundesweit.de/Wpts_080504_134712.gpx

Viele Grüße, Kai

-------- Original-Nachricht --------
Datum: Tue, 06 May 2008 14:07:06 +0200
Betreff: Re: [Talk-de] Problem mit GPS-Tuner, Waypoints in OSM
Hallo,
Post by Kai Behncke
ich erhebe meine Daten mit der Software "GPS Tuner". Ich habe da nun
Wegpunkte abgespeichert die ich nun in JOSM bearbeiten möchte.
Post by Kai Behncke
Wenn ich allerdings meine Waypoint-gpx-Datei einladen möchte erhalte
Error while parsing......Content is not allowed in prolog.
Kannst Du uns so eine Datei mal irgendwo zum Download bereitstellen?
Bye
Frederik
_______________________________________________
Talk-de mailing list
http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/talk-de
--
Ist Ihr Browser Vista-kompatibel? Jetzt die neuesten
Browser-Versionen downloaden: http://www.gmx.net/de/go/browser
Frederik Ramm
2008-05-06 12:57:46 UTC
Permalink
Hallo,
Post by Kai Behncke
danke für die Bemühungen.
http://www.selbstverwaltung-bundesweit.de/Wpts_080504_134712.gpx
Da ist ein seltsames UTF-8-Zeichen am Anfang, wenn man das leoscht, dann
laedt JOSM die Datei. Allerdings auch mit komischen Ergebnissen, weil in
der Datei ueberall sowas wie <![CDATA ... ]]> drinsteht... vielleicht
kann sich das mal jemand anders anschauen, ich hab dieses Format noch
nicht gesehen. Ist das normal? Kann man das mit gpsbabel in etwas
brauchbareres umwandeln?

Bye
Frederik
Kai Behncke
2008-05-06 13:11:38 UTC
Permalink
Hallo Frederik,
danke, das bringt mich schon etwas weiter.

Aber welches UTF-8-Zeichen meinst Du?

Viele Grüße, Kai

-------- Original-Nachricht --------
Datum: Tue, 06 May 2008 14:57:46 +0200
Betreff: Re: [Talk-de] Problem mit GPS-Tuner, Waypoints in OSM
Hallo,
Post by Kai Behncke
danke für die Bemühungen.
http://www.selbstverwaltung-bundesweit.de/Wpts_080504_134712.gpx
Da ist ein seltsames UTF-8-Zeichen am Anfang, wenn man das leoscht, dann
laedt JOSM die Datei. Allerdings auch mit komischen Ergebnissen, weil in
der Datei ueberall sowas wie <![CDATA ... ]]> drinsteht... vielleicht
kann sich das mal jemand anders anschauen, ich hab dieses Format noch
nicht gesehen. Ist das normal? Kann man das mit gpsbabel in etwas
brauchbareres umwandeln?
Bye
Frederik
_______________________________________________
Talk-de mailing list
http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/talk-de
--
Ist Ihr Browser Vista-kompatibel? Jetzt die neuesten
Browser-Versionen downloaden: http://www.gmx.net/de/go/browser
Frederik Ramm
2008-05-06 14:17:07 UTC
Permalink
Hallo,
Post by Kai Behncke
Aber welches UTF-8-Zeichen meinst Du?
Das Zeichen "<feff>". In meinem vi wurde es mir nur angezeigt, wenn ich
ihn mit der "-b"-Option aufgerufen habe, ansonsten sieht man es nicht.
Es handelt sich wohl im ein "non breaking zero width space", das
zuweilen auch als "byte order mark" verwendet wird.

Bye
Frederik
Jens Poenisch
2008-05-06 18:20:01 UTC
Permalink
Post by Frederik Ramm
Das Zeichen "<feff>". In meinem vi wurde es mir nur angezeigt, wenn ich
ihn mit der "-b"-Option aufgerufen habe, ansonsten sieht man es nicht.
Es handelt sich wohl im ein "non breaking zero width space", das
zuweilen auch als "byte order mark" verwendet wird.
Meines Wissens ist das die Kennzeichnung für UTF-16(!)-Codierung, also
2 Byte pro Zeichen. Das könnte vielleicht die Probleme verursachen.

Jens
--
Jens Poenisch, EMail: jens.poenisch-***@public.gmane.org
- Bisher haben die Astropsychologen noch nicht herausgefunden,
woran die Elefanten denken. -- T. Pratchett
->An Elefantinnen, meint OJe
Andreas Jacob
2008-05-06 13:58:17 UTC
Permalink
Post by Frederik Ramm
Da ist ein seltsames UTF-8-Zeichen am Anfang, wenn man das leoscht, dann
laedt JOSM die Datei.
Jupp, bei mir auch. (Hex: EF BB BF)
Post by Frederik Ramm
Allerdings auch mit komischen Ergebnissen, weil in
der Datei ueberall sowas wie <![CDATA ... ]]> drinsteht...
Soweit meine bescheidenen XML Kentnisse richtig sind, wird CDATA dann
verwendetm wenn man das Auftreten von, im Sinne von XML, Sonderzeichen wie
z.B. die eckigen Klammern im Text zulassen will. Sozusagen ein Quoting.

Gruß Andreas
Raphael Mack
2008-05-10 18:05:48 UTC
Permalink
Post by Andreas Jacob
Post by Frederik Ramm
Allerdings auch mit komischen Ergebnissen, weil in
der Datei ueberall sowas wie <![CDATA ... ]]> drinsteht...
Soweit meine bescheidenen XML Kentnisse richtig sind, wird CDATA dann
verwendetm wenn man das Auftreten von, im Sinne von XML, Sonderzeichen
wie z.B. die eckigen Klammern im Text zulassen will. Sozusagen ein
Quoting.
Ja genau da ist der Haken. Gpx ist halt ein XML-Format und JOSM verwendet
keinen XML-Parser um es zu lesen. Darum können wir auch mit
solchen ?tollen? XML-Features nicht umgehen... Wenn sowas von mehreren
Gpx-Quellen produziert wird, müsste man das ggf. mal umstellen...

Rapha
Christian Matzat
2008-05-13 15:09:07 UTC
Permalink
Die drei Zeichen am Anfang sind der erste Fehlergrund weil nach den
XML-Spezifikationen vor dem <?xml version="1.0"?> nichts anderes
erlaubt ist und der verwendete XML-Parser eine Content-Prüfung macht.
Das sagt auch die Fehlermeldung aus (Content is not allowed in prolog).
Post by Raphael Mack
Post by Andreas Jacob
Post by Frederik Ramm
Allerdings auch mit komischen Ergebnissen, weil in
der Datei ueberall sowas wie <![CDATA ... ]]> drinsteht...
Soweit meine bescheidenen XML Kentnisse richtig sind, wird CDATA dann
verwendetm wenn man das Auftreten von, im Sinne von XML,
Sonderzeichen
wie z.B. die eckigen Klammern im Text zulassen will. Sozusagen ein
Quoting.
Ja genau da ist der Haken. Gpx ist halt ein XML-Format und JOSM verwendet
keinen XML-Parser um es zu lesen. Darum können wir auch mit
solchen ?tollen? XML-Features nicht umgehen... Wenn sowas von mehreren
Gpx-Quellen produziert wird, müsste man das ggf. mal umstellen...
JOSM verwendet zum Importieren der GPX-Daten einen SAX-Parser. Der
wertet <![CDATA[ ]]> natürlich auch richtig aus, soll heißen in den
resultierenden Strings ist das <![CDATA[ ]]> nicht mehr drin. Daran
liegt die "komische" Anzeige nicht begründet.

In den einzelnen Wegpunkten sind aber Link-Tags drin, die JOSM
speichert (ohne Inhalt, da leer) und später versucht aufzulösen, was
nicht geht, da leer.

Viele Grüße,
Christian

Continue reading on narkive:
Loading...